Nandroid backup, hash check fails

Home Forums Nexus Root Toolkit Backup/Restore Support Nandroid backup, hash check fails

This topic contains 6 replies, has 6 voices, and was last updated by  kellogg9 10 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7786

    Larwood
    Participant

    I have tried several times to do a nandroid backup with a few different settings, but it fails at the hash check every single time. The files do end up on my PC. My most recent attempt was just a data partition backup, no compression – full log: http://hastebin.com/imukeposum.tex

    #7861

    EventHorizon
    Participant

    Having the same issue. Checking the backup files manually and comparing to the md5 generated on backup shows that the files are valid (verified and checked w/Cygwin md5sum) for all the .WIN files that are created.

    #7865

    EventHorizon
    Participant

    And just to show the md5sum check is correct:
    $ for i in ls *.md5
    > do
    > name=echo ${i:0:-4}
    > cat $i
    > md5sum $name
    > done
    5a7714ceb8aac583ba1e699ada63b3ed boot.emmc.win
    5a7714ceb8aac583ba1e699ada63b3ed *boot.emmc.win
    f09caa5e939473fbbcb673e08675adf3 data.ext4.win000
    f09caa5e939473fbbcb673e08675adf3 *data.ext4.win000
    6524ee4d6ce96a93c412c01206aa2f60 data.ext4.win001
    6524ee4d6ce96a93c412c01206aa2f60 *data.ext4.win001
    eeccf0f8e49b9e486f2b391f0e520496 data.ext4.win002
    eeccf0f8e49b9e486f2b391f0e520496 *data.ext4.win002
    3575c0878eccf349f23f580fd0f79635 data.ext4.win003
    3575c0878eccf349f23f580fd0f79635 *data.ext4.win003
    f14e771b6981d88baa0cfba5a3bfda1b data.ext4.win004
    f14e771b6981d88baa0cfba5a3bfda1b *data.ext4.win004
    b922c5be17d7d82d0bb7eb2a9e408e12 recovery.emmc.win
    b922c5be17d7d82d0bb7eb2a9e408e12 *recovery.emmc.win
    5bb6cdc8993282bb1fecd537f00203cb system.ext4.win
    5bb6cdc8993282bb1fecd537f00203cb *system.ext4.win

    #9446

    JayinMD
    Participant

    Same problem (MD5 Verification errors) doing a full Nandroid backup from NRT V2.1.6 of a Nexus 10. However I noticed that when I use “Raymond Lin’s MD5 & SHA-1 Checksum Utility” to check the files using the existing MD5s it changes the alpha characters in the MD5 to upper case and verifies the backup file. Is this a TWRP or Nandroid problem?

    I love NRT and wish I had discovered it a long time ago. Thanks for the work!

    #9634

    WugFresh
    Keymaster

    This is an NRT issue. Your files are being properly backed up to your comp, but the hashcheck for that operation is using an incorrect file path. This hashchecking system was something I created that is very unique, and just wasn’t quite right for that operation in current public release. v2.1.7 is near completion and this is fixed, among many other improvements.

    #12639

    ccrobin
    Participant

    Is there a workaround for this then? I am attempting to restore a nandroid backup. Can I use a different tool? I tried checking to ignore MD5 verification but it seems to still error out.

    #24581

    kellogg9
    Participant

    Seems this bug is back but just for when you do a Restore (of Nanoid). It seems when it does a md5 check on the files it pushed to the phone it is giving the incorrect file path. So i get a lot of file not founds and hence md5 fails.

    I get a sense the author has abandoned this project but felt i should post anyway for posterity reasons so random people in the distance future who do come here by accident will see and say “ohh that poor soul never did get a reply”, chuckle, and hit the back button. 🙁 🙁

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.