Get ADB Recovery Device not found, but no 'exclamtation marks' in device manager

Home Forums Nexus Root Toolkit Rooting Support Get ADB Recovery Device not found, but no 'exclamtation marks' in device manager

Tagged: , ,

This topic contains 2 replies, has 3 voices, and was last updated by  puzzlesolver 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12966

    stanton_ab
    Participant

    I recently decided to reroot my nexus 6p (android 7.0), (the bootloader was still unlocked) so I went through the necessary driver uninstallations and installations. Ran the test and got success.
    Pressed root, all went fine until it launched twrp temporarily, and twrp asked for a password, and nexus root toolkit said I needed to install ADB recovery device, and asked to look for exclamation mark in device manager. There was no exclamation mark, and no device drivers needed updating..
    Don’t know what the problem is, and any help would be very welcome,

    thanks

    • This topic was modified 2 years, 6 months ago by  stanton_ab.
    #13008

    Joe
    Participant

    +1

    #13037

    puzzlesolver
    Participant

    I have the same issue with an old Nexus S. I’ve tried uninstalling all drivers and reinstalling different versions. When I run the Driver tester, it shows success.
    As far as I know the phone is rooted. The ADB recovery error only pops up on the root function if you check the box “custom recovery.”
    the first time I saw the ADB Recovery Device Not Found was when I tried to install a new Rom. It did everything up to TWRP mode, then couldn’t find the ADB Recovery Device.
    I think it has something to do with installing the right ADB driver while the phone is in either Bootloader or TWRP mode. I just have no idea what driver that is.
    Unfortunately, I’m a newbie to this in the last week- trying to get a Nexus S in workable condition for my son.
    I’ve also tried using an older Wugfresh Rootkit version, but I’m not even sure if those older drivers ever got loaded as the system would often tell me the latest version was already installed.
    Somewhere, there must be a simple driver to upload that would solve the problem, but I have yet to find it.
    I also can’t understand why the Rootkit doesn’t discover the problem when running the test to see if you have all the right drivers.
    Extremely frustrating.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.