ADB Recovery device was not found – I already HAD root

Home Forums Nexus Root Toolkit Rooting Support ADB Recovery device was not found – I already HAD root

This topic contains 16 replies, has 12 voices, and was last updated by  Beardfactor 2 years ago.

Viewing 2 posts - 16 through 17 (of 17 total)
  • Author
    Posts
  • #13115

    puzzlesolver
    Participant

    I have a Nexus S i9020t and had gotten through all the steps until I was installing a custom Rom (eventually CM-12). I tried using the toolkit: Advance Utilities (Launch), “Flash Zips From:”, check “Computer”
    It would go through all the steps, then after rebooting in TWRP mode, give the error: “ADB Recovery Device was not found” I kept banging my head against the wall doing all the above steps and any others I could find. No luck.
    I do think, though, that it does have something to do with file transfer settings after it restarts in TWRP mode. Somehow the PC is no longer able to communicate with the phone in that mode. Keep in mind, I’m really over my head with all this.
    In any case, what finally DID work:
    I went back to normal mode I copied the zip file from my PC to the phone’s internal SD card. I can’t remember what it took to see the phone’s SD card through the PC, but perhaps it was simply turning on USB debugging.
    Again, through “Advanced Utilities”, this time I clicked install from SD card.
    Again it went through some steps, but after it rebooted in TWRP mode, couldn’t continue. At that point, though, through TWRP itself on the phone, I wiped the data, then installed the Rom. This was done simply by clicking on the “Wipe” square, followed by the “Install” square.
    After it tried to install the new ROM, I would get an MD5 error. (Apparently, this has something to do with matching the PC file version with the version on your phone.) Again, I thought I was screwed. I rebooted the phone.
    The new Cyanogen Mod (CM-12) booted up.
    I then repeated the process for installing the GApps. However, it did take me a while to be able to see the SD card through the PC. That time, I did have to click on USB debugging.
    Hope that helps someone and they don’t waste 20 hours on this like I did.

    #14824

    Beardfactor
    Participant

    It worked perfect. Thank you!

Viewing 2 posts - 16 through 17 (of 17 total)

You must be logged in to reply to this topic.